
 

 

RegCool - Help File 

RegCool is an extremely flexible editor for the Windows registry database 

Advanced Registry Editor: RegCool is an extremely flexible editor for the Windows registry 

database. The program offers an attractive interface, convenient context menus and a practical 

toolbar that puts extensive editing functions at your fingertips. RegCool provides the complete 

functionality of Windows' own Regedit, but adds a number of additions. A bookmark editor 

highlights keys and allows you to add short notes to them - making it easy to return to hard-to-

reach keys. Find and replace, remote editing, key import and export, comparison of registry keys, 

RegShot function, backup and restore as well as a multi-level undo function are among the 

numerous additions that RegCool has to offer. 

 

Undo function - Multiple undo and redo of the last action. Undo history is saved on the hard disk. 

Find & replace - Search and replace registry keys, values and data with a very fast search algorithm. In 

the search results, the search term can be replaced with another term. 

Compare - Very fast comparison of registry keys from different computers. 

RegShot function - Comparison of two snapshots of registries. 

Cut, Copy & Paste - Cut, copy and paste registry keys and values. 

Backup & Restore - Complete backup and restore of the registry. 

Defragmentation - Repairs structural defects, frees up unused memory and increases system 

performance. 

Favorites management - Simple and effective management of favorites. 

Multiple opening - Multiple opening of local registries. 

Hidden keys - Opening hidden keys. 

 

asar://app.asar/web/app/builder/regcool_en.html


Caution: 

Incorrect editing of the registry can cause serious computer damage. Before making changes to the 

registry, make a backup of all important computer data. 

 

RegCool startup behavior 

In the options you can set the default startup of RegCool: 

1) No administrator rights, 

2) Administrator rights, 

3) With system rights (CAUTION: All keys are open). 

A quick start is supported in the main menu: If you have no rights, you can quickly start RegCool in 

the main menu as an administrator or with full access. If you have administrator rights, you can 

quickly start RegCool in the main menu with full access. Otherwise RegCool starts with the default 

setting in the options settings. 

 

Registry 

The registry is a database that contains system configuration information for the operating system 

and consists of two parts: The first part contains configuration data for the entire Windows 

installation, the second part contains all user-specific information and settings. Registry entries are 

created in a tree structure in keys, all of which are derived from some master keys. 

 

The registry is divided into five logical sections, which are further divided into subsections and keys. 

Registry sections: HKEY_CLASSES_ROOT, HKEY_LOCAL_MACHINE, HKEY_CURRENT_USER, 

HKEY_USERS and HKEY_CURRENT_CONFIG. 

 

Overview of keys 

HKEY_CLASSES_ROOT HKCR Information about the various COM objects and file types. This includes 

the description, the icon and the associated application. 

Merging of subkeys in HKEY_LOCAL_MACHINE\Software\Classes and 

HKEY_CURRENT_USER\Software\Classes 

HKEY_CURRENT_USER HKCU Admins: Full access, User: Full access (to own) User profile of the 

currently logged in user, link to subkey of HKEY_USERS 

HKEY_LOCAL_MACHINE HKLM Admins: Full access, User: Read only. Settings and information shared 

by all users are stored here. 

HKEY_USERS HKU Admins: Full access, User: Access only to own. Contains the root of all user profiles 

on the computer. Settings and information that are unique to the specific Windows user are stored 

here. 

HKEY_CURRENT_CONFIG HKCC Admins: Full Control, User: None currently used hardware profile, 

links to subkey of HKEY_LOCAL_MACHINE. 

 

Registry Data Types 

REG_BINARY Raw binary data. Most information about hardware components is stored as binary data 

and displayed in hexadecimal format in Registry Editor. 

REG_DWORD Data represented by a number. 

REG_EXPAND_SZ Expandable string. 

REG_MULTI_SZ Multi-string. Values that contain lists or multiple values in plain text are usually of this 

type. 

REG_SZ This is a sequence of characters that represent plain text. 

 

To add a registry key 



On the registry tree (on the left), click the registry key under which you want to add a new key. 

On the Edit menu, point to New Key. 

Type a name for the new key, and then press ENTER. 

 

To add a value to a registry key entry 

Click the key or entry to which you want to add the new value. 

On the Edit menu, point to New Value, and then click the type of value you want to add: String, 

Binary, DWORD, Multi-String Value, or Expandable String Value. 

Type a name for the new value, and then press ENTER. 

 

To rename a registry key or value 

Click the key or entry you want to rename. 

On the Edit menu, click Rename. 

Type the new name, and then press ENTER. 

 

To delete a registry key or value 

Click the key or entry you want to delete. 

On the Edit menu, click Delete. 

 

To change a value 

Select the entry you want to change. 

On the Edit menu, click Modify. 

In the Value data box, enter the new data for the value, and then click OK 

 

To add a registry key to Favorites 

Identify the registry key you want to add to Favorites. 

On the Favorites menu, click Add to Favorites. 

The registry key is added to the Favorites list. 

 

To copy a registry key name 

Open Registry Editor. 

Click a registry key in the Registry tree (on the left). 

On the Edit menu, click Copy Key Name. 

Paste the registry key name into another program or document. 

 

Finding data in the registry 

On the Edit menu, click Find. 

In the Find what field, type the string, value, or key you want to find. 

Select the check boxes you want for the search, such as Keys, Values, Data, and Match entire string, 

and then click Find. 

After the search is complete, all results are listed in a list that you can sort by name, key, or type as 

you wish. 

 

Replacing in the search results 

In the search results, click Replace. 

In the Replace dialog, enter the search term, and under Replace, enter the term you want to replace. 

Select the Search Keys, Search Values, Search Data, and Match Case, Match entire string check boxes 

to match the type of search you want. Click OK. 

NOTE: 



Binary values are not replaced. 

 

To connect to a registry over the network 

On the File menu, click Connect to Network Registry. 

In the Select Computer dialog box, enter the name of the computer whose registry you want to 

connect to. 

 

To disconnect from a network registry 

Close the associated window. 

 

To compare the contents of two keys 

Specify the open registry of the first key. 

Specify the first key to compare. 

Specify the open registry of the second key. 

Specify the second key to compare. 

Click Compare Registries. 

 

Offline Registry 

RegCool is able to treat a set of registry hive files as a separate standalone registry. Specify a folder 

containing registry hive files and load specific files from that folder as hives. The following files are 

loaded as corresponding subkeys of HKEY_CURRENT_USER: ntuser.dat, HKEY_LOCAL_MACHINE: SAM, 

SECURITY, SOFTWARE, SYSTEM and HKEY_USERS: .DEFAULT. Only the following names are recognized 

in this folder: ntuser.dat, SAM, Security, Software, System and DEFAULT. If you want to load other hive 

files, simply e.g. rename the XYZ file to DEFAULT or Security and open it. Viewing and editing the key 

security information is not implemented. 

 

Click Open Offline Registry. 

Specify the folder where the hive files are located. 

Also individual HIVE files can be loaded under the HKEY_CURRENT_USER key 

 

Edit .REG and .HIVE files offline 

Click New Registry. 

Create keys and values offline, import .reg or .hive files and save them as .reg or .hive files after 

editing. 

NOTE: When closing the active tab, you have the option to save open keys as .hive files. 

Opening .reg files offline via the Explorer context menu 

 

Command line arguments 

Command line option syntax 

/h Help file output 

/j [regpath] Opens RegCool and jumps to the key [regpath]. 

/edit [filepath] RegCool opens the .reg file [filepath] in a new window offline for editing. 

/s Silent mode. Performs an action without stopping for confirmation with a dialog box. 

/m Opens an additional RegCool instance that can be useful for troubleshooting to compare registry 

entries. 

/export [filepath] [regpath] Exports a registry key [regpath] to a file with the extension .reg [filepath]. 

/d [regpath] Removes a registry key [regpath] from the registry. 

/import [filepath] Imports a registry file [filepath] into the Windows registry. 

/s [filepath] Imports a registry file [filepath] into the Windows registry without confirmation. 



/qc [server1;server2] Quickly connects to a remote registry. 

Example: RegCool /export c:\temp.reg "HKEY_CURRENT_USER\Control Panel" 

Example: RegCool /edit "c:\myfolder\temp.reg" 

 

How to create a snapshot of the registry 

Determine the registry that is open. 

Determine whether the entire registry or only a partial branch should be taken into account. 

Click Create Shot 1. 

After making changes to the registry (e.g. installation), click Create Shot 2. 

Click Compare Registries. 

 

How to create a backup of the registry 

On the Tools menu, click Backup & Restore Local Registry. 

Click Create Backup. 

Determine the hives to be backed up and click OK. 

 

How to restore the registry 

On the Tools menu, click Backup & Restore Local Registry. 

Select the backup you created previously. 

Click Restore and follow the instructions. 

 

Keyboard shortcuts 

Ctrl+F Opens the Find dialog box. 

F1 Displays RegCool Help 

F2 Renames the selected subkey or value 

F5 Refreshes the key and value panes 

F10 Opens RegCool's main menu 

Ctrl+Shift+F10 Displays the context (right-click) menu for the selected subkey or value 

Alt+F4 Closes RegCool 

TAB Switch between the Key, Value, History, Search 1, Search 2, Compare, Favorites, and Reg Compare 

panes. 

Ctrl+Shift+T reopens the last closed tab. 

F6 Switch between the open registry tabs 

Keypad + (NUM +) Expands the children of the selected subkey 

Keypad - (NUM -) Collapses the children of the selected subkey 

Keypad * (NUM *) Expands all subkeys of the selected branch (this takes a few seconds if there are 

many subkeys). 

Ctrl+C Copies the selected keys and values 

Ctrl+X Cuts the selected keys and values 

Ctrl+V Pastes the selected keys and values 

Ctrl+E Exports the current key or entire registry to a file 

Ctrl+Z Undoes the last action 

Ctrl+Y Redoes the previously undone action 

Ctrl+K Creates a new key 

Del Deletes the selected items 

Ctrl+A Selects all contents 

Ctrl+L Opens a new local registry 

Ctrl+N Creates a new local registry file 

Ctrl+O Loads an offline registry from a folder 



Ctrl+D Loads an offline registry from a file 

Enter Opens the selected value for editing 

F7 Closes the active tab 

Up arrow Selects the previous subkey 

Down arrow Selects the next subkey 

Right arrow Expands the selected subkey if it is collapsed; otherwise, it selects its first child 

Left arrow Collapses the selected subkey if it is expanded. otherwise the parent of the subkey is 

selected 

Home Selects the top subkey of the key range 

End Selects the top subkey of the key range 

Ctrl+Shift+B Create new REG_BINARY value 

Ctrl+Shift+D Create new REG_DWORD value 

Ctrl+Shift+S Create new REG_SZ value 

Ctrl+Shift+M Create new REG_MULTI_SZ value 

Ctrl+Shift+E Create new REG_EXPAND_SZ value 

Ctrl+Shift+G Create new REG_DWORD_BIG_ENDIAN value 

Ctrl+Shift+Q Create new REG_QWORD value 

Ctrl+Shift+R Create new REG_RESOURCE_LIST value 

Ctrl+Shift+F Create new REG_FULL_RESOURCE_DESCRIPTOR value create 

Ctrl+Shift+T Create new REG_RESOURCE_REQUIREMENTS_LIST value 

 

Installer command line 

RegCool.exe /si This performs a silent installation with default options. (quiet) 

RegCool.exe /Dir= Replace the default folder with a custom installation path. 

Additional parameters 

/re create system restore point 

/st create start menu entries 

/de create desktop shortcut 

/la start program after installation 

/up automatically check for updates 

/us install for all users 

/lg install with a language file identified by an ID (RegCool.exe /lg=lang_en) 

RegCool.exe /si /dir=C:\DirectoryToInstall /re /st 

would silently install RegCool.exe in the C:\DirectoryToInstall folder, create a system restore point and 

create start menu entries 

 

ID language file identifiers 

lang_de = German 

lang_en = English 

lang_fr = French 

lang_es = Spanish 

lang_hu = Hungarian 

lang_pt = Portuguese 

lang_nl = Dutch 

lang_ru = Russian 

lang_cs = Chinese (simplified) 

lang_ct = Chinese (traditional) 

lang_hi = Hindi 

lang_jp = Japanese 



lang_it = Italian 

lang_tr = Turkish 

lang_ar = Arabic 

lang_ko = Korean 

lang_sl = Slovenian 

lang_bg = Bulgarian 

lang_pl = Polish 

lang_sw = Swedish 

lang_pk = Urdu – Pakistan 

lang_bd = Bengali (India) 

lang_vn = Vietnamese 

lang_su = Swahili 

lang_id = Indonesian 

lang_no = Norwegian 

lang_dk = Danish 

lang_gr = Greek 

lang_fi = Finland 

lang_th = Thailand 

lang_uz = Uzbekistan 

lang_hr = Croatia 

lang_lv = Latvia 

lang_ee = Estonia 

 

Supported RegEx operators for searching 

. Period, matches any single character except a newline. 

^ Caret, matches the beginning of the line or string the regular expression is searching. 

$ Dollar, matches the end of the line or string the regular expression is searching. 

* Asterisk, matches zero or more + Plus, matches one or more 

? Question, matches zero or any of the preceding characters. 

{n} Matches the preceding expression exactly n times. 

{n,} Matches n or more times 

{n,m} Matches the preceding expression at least n times and at most m times. 

[abc] Matches any of a, b, and c. 

[^abc] A caret ^ at the beginning of the square bracket means "not," in which case it matches 

anything except a, b, or c. 

[a-zA-Z] Character ranges, the character set of the ranges { a-z | A-Z } 

\s Matches a space, \t \f \r \n \v and spaces 

\S Matches a non-space character. 

\w Matches an alphanumeric character., [a-zA-Z0-9_] 

\W Matches a non-alphanumeric character. 

\d Matches a digit [0-9]. 

\D Matches a non-digit. 

| OR operator (|): For example, the regular expression four|4 accepts the strings "four" or "4". 

  


